输入banner图图片脚本导航/分类

MySQL主从配置问题整理

CHANGE MASTER TO -> MASTER_HOST=‘192.168.3.1‘, -> MASTER_USER=‘slaveuser‘, -> MASTER_PASSWORD=‘password‘, -> MASTER_PORT=3306, -> MASTER_LOG_FILE=‘mysql-bin.000001‘, -> MASTER_LOG_POS=120; Query OK, 0 rows affected, 2 warnings (0.02 sec)

3.遇到如下问题:

问题一:

mysql> start slave;
ERROR 1872 (HY000): Slave failed to initialize relay log info structure from the

解决方法:

stop slave;
reset slave;
start slave;

问题二:

Last_IO_Error: Fatal error: The slave I/O thread stops because master and slave have equal MySQL server UUIDs; these UUIDs must be different for replication to work.

解决方法:

修改auto.conf文件,更改与主库不同的uuid,重启mysql即可。

 

MySQL主从配置问题整理

标签: