输入banner图图片脚本导航/分类

升级WAMPSERVER后运行php程序总报错,求助!

将WAMPSERVER升级到2.2(Apache 2.4.2; PHP 5.4.3; MySql 5.5.24)后运行php程序,总是报错,不知如何解决,求诸位指点。多谢

测试用源码如下:
Window I	



错误截屏如下:


回复讨论(解决方案)

31行 $item_name 变量没有定义
38行 $itemname 变量没有定义

那是因为之前的php的notice被你屏蔽了,升级后,配置又恢复了默认吧,所以notice又开启了

你的变量没定义
如果原来正常 有可能是打开了 register globals

php.ini
改
error_reporting = E_ALL & ~E_NOTICE & ~E_STRICT